Intermittent accessibility to historical DNS records
Incident Report for SecurityTrails
Resolved
We confirmed that all systems are operational again. Should you have any issues, please contact support@securitytrails.com or visit our live chat.
Posted Nov 05, 2019 - 18:59 UTC
Update
We are continuing to monitor for any further issues.
Posted Nov 05, 2019 - 17:00 UTC
Monitoring
This incident has been resolved. Our team is proactively monitoring all the services.
Posted Nov 05, 2019 - 16:59 UTC
Investigating
We are currently experiencing intermittent service accessibility to historical DNS records.

Our engineering team is working to identify the root cause and implement a solution.

We will continue to send additional updates every 60 minutes until the incident is resolved.
Posted Nov 05, 2019 - 16:15 UTC
This incident affected: Website & Public App and SecurityTrails API™.